The minimum requirements to be able use the BBC micro:bit are as follows;

  • Windows 7 or later
  • Mac OS X 10.6 or laterĀ 
  • Linux